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New Developments in BioWin 5.1

The primary focus of this release has been to improve both steady state and dynamic simulation speed,
particularly for (a) large flowsheets incorporating many elements; and (b) systems incorporating biofilm
elements (e.g. media bioreactors in MBBR and IFAS configurations, submerged aerated filters, trickling

filters, etc.).

Speed Improvements - Steady State Simulation

The basic methodology for steady state simulations remains unchanged. That is, BioWin uses a
“hybrid” solver that combines a Decoupled Linear Search (DLS) method and a Modified
Newton-Raphson (MNR) method. The solver typically starts with a few iterations of DLS, and
then switches to MNR to finish. The MNR is much more efficient at obtaining solutions, but it is
computationally intensive. For example, in previous versions of BioWin, the MNR could take up
to several minutes per iteration for systems with large, complex flowsheets. Given that several
iterations often are required, this translated into steady state solution times of 20-30 minutes
for very large systems.

In BioWin 5.1, the numerical engine underlying the MNR method has been replaced, resulting
in huge gains for large flowsheets. For example, in our internal testing we have systems that
were taking ~200 seconds per iteration reduce to ~4 seconds per iteration, i.e. 50 times
faster!

Speed Improvements - Dynamic Simulation
BioWin 5.1 uses a new dynamic integration method known as BDF (Backwards Differentiation
Formula). The BDF method is faster than the previous method for large, complex flowsheets

and flowsheets incorporating biofilm-based elements. Our BioWin 5.1 testing has indicated:

e Large systems not incorporating biofilm reactors run 3 — 6 times faster
e Systems incorporating biofilm reactors run 10 — 50+ times faster

If you open the Project > Current Project Options > Numerical parameters tab shown below,
the BDF method should be selected as the default method — even for a file you created in a



previous version of BioWin. The “old” BioWin method (BWHeun) is also still available because
the new BDF method is not yet available for simulation of SBR systems.
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Model Change - Diffusion of Colloidal Material in Biofilms

BioWin’s biofilm model has always incorporated a diffusion rate for colloidal material into the

biofilm layers. This parameter can be found on the Project > Parameters > Biofilm > Effective
diffusivities tab shown below:



& - BioFilm properties editor X
Biofilm general | Maximum biofilm concentrations [mg/L] ~ Effective diffusivities [m2/s] I EPS Strength coefficients [ ] I
Parameters
Name Default Value |Anhenius | A
Endogenous products 5.000E-14 |5.000E-14  1.0290
Slowly bio. COD (part.] 5.000E-14 [5.000E-14 1.
Slowly bio. COD [colloid.) 5.000E-12  |5.000E-12
Part. inert. COD 5.000E-14 |5.000E-14  1.0230
Part. bio. org. N 5.000E-14 |5.000E-14 1.0290
Part. bio. org. P 5.000E-14 |5.000E-14  1.0230
Part. inert N 5.000E-14 |5.000E-14  1.0230
Pat. inert P 5.000E-14 [5.000E-14  1.0290
Stored PHA 5.000E-14 |5.000E-14 1 1.0290
Releasable stored polyP 5.000E-14 |5.000E-14  1.0290
Fixed stored polyP 5.000E-14 |5.000E-14  1.0290
Readily bio. COD [complex) 6.900E-10  |6.900E-10  1.0230
Acetate 1.240E-9 1.240E-9 1.0290
Propionate 8.300E-10  |8.300E-10  1.0290
Methanol 1.600E-9 1.600E-9 10230 |,
Print all Set current tab to default values Cancel

In previous versions of BioWin, the default value assigned for the effective diffusivity of
colloidal material was 5.0 x 10", This value is greater than the one assigned to particulate
material (e.g. particulate degradable COD has a value of 5.0 x 10™*%), but lower than soluble
material (e.g. soluble readily biodegradable COD has a value of 6.9 x 10™'%). The fate of colloidal
material in biofilm systems is directly impacted by this parameter value. For example, consider
the system below consisting of four moving bed bioreactor (MBBR) units in series:

% BioWin Simulator - Simple MBBR BW 50 80D Profile.bwe - o x
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Using the default diffusivity parameters, the soluble COD and BOD profiles are as follows:
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Note that soluble BOD is not significantly reduced until the end of the third MBBR unit (bottom

chart). This can be explained by looking at the top chart. Although the uptake of soluble readily

biodegradable material is nearly complete by the end of the second unit, the uptake of colloidal
material is not as rapid and much of the soluble BOD leaving the second and third MBBR units is
due to colloidal material.

Our investigations into performance of systems like the one pictured above suggests that the
soluble BOD is removed to a greater extent by the end of the second stage. As a result, in
BioWin 5.1 the default value assigned for the effective diffusivity of colloidal COD material has
been increased to 5.0 x 10™'°. This value is closer to, but slightly less than, the value assigned to
soluble material (recall that soluble readily biodegradable COD has a value of 6.9 x 10™°). This
results in more complete removal of colloidal material by the end of the second stage, and
gives the soluble BOD profile shown below:
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Model Change - Dissolved Oxygen Half-Saturation Constant for Phosphorus
Accumulating Organisms

In previous versions of BioWin, the phosphorus accumulating organisms (PAO) used the same
dissolved oxygen (DO) half-saturation model parameter as the ordinary heterotrophic
organisms (OHO). This reflected conventional wisdom which suggested that PAOs did not take
up phosphorus effectively at low DO concentrations. However, current research (Jimenez et al.,
2014) suggests that PAOs are in fact able to take up phosphorus effectively at very low DO
concentrations. To reflect these findings, BioWin now incorporates a separate dissolved oxygen
(DO) half-saturation model parameter for PAOs. This improves the model’s ability to track
biological phosphorus removal behavior in systems operating under low DO / simultaneous
nitrification-denitrification conditions. This parameter is found via the Project > Parameters >
Kinetic > Switches tab shown below:



!.r Kinetic parameter editor X
Common | A0B | NOB | 440 | OHO | Methylotiophs | PAQ | Acetogens | Methanogens | pH ~ Switches I
Parameters

Name Default  |value | ~

(OHO DO half sat. [mgO2/L] 0.0500 [0.0500

PAO DO half sat. [mgO2/L] 0.0500 0.0500

Anoxic/anaerobic NOx half sat. [mgN/L] 0.1500  |0.1500

AOB DO half sat. [mgO2/L] 0.2500 0.2500

INOB DO half sat. [mgO2/L] 0.5000 0.5000

AAO DO half sat. [mgO2/] 0.0100 0.0100

Anoxic NO3(->NO2) half sat. [mgN/L] 0.1000 0.1000

Anoxic NO3(->N2) half sat. [mgN/L] 0.0500 |0.0500

Anoxic NO2(->N2) half sat. (mgN/L) 0.0100 0.0100

INH3 nutrient half sat. [mgN/L] 0.0050 |0.0050

PolyP half sat. [mgP/mgCOD] 0.0100 0.0100

VFA sequestration half sat. [ngCOD/L] 5.0000 5.0000

P uptake half sat. [mgP/L] 0.1500 0.1500

P nutrient half sat. [mgP/L] 0.0010 0.0010

Autotroph CO2 half sat. [mmol/L] 0.1000 0.1000

H2 low /high half sat. [ngCOD/L] 1.0000 1.0000 v

Print all Set current tab to default values Cancel

Model Change — Compression Settling of Solids

In BioWin users can define a solids concentration that represents the maximum compactability
of solids in a model settling tank unit (i.e. a limit on underflow TSS concentration). In earlier
versions, as the solids concentration in a layer of a model settling tank approached the
maximum compactability value, that layer would “re-suspend” solids into the layer above; in
this way the constraint on maximum compactability was maintained. This approach was not
always satisfactory because (a) under certain conditions it resulted in unstable behavior, and (b)
it did not properly reflect what physically occurs as solids transition from the hindered settling
regime to compression settling.

In BioWin 5.1, the approach for modelling settling behavior at high solids concentrations and
imposing a maximum compactability has changed. The following section discusses the new
approach used at high solids concentrations, as well as the approach that has always been used
to model settling at low concentrations.

Sludge settling velocity is modeled according to the Vesilind equation for hindered settling. The
settling velocity in a given layer is given by:

Vs‘i = VO e_KXi (1)
where V/; = maximum settling velocity (m/d), K = hindered settling parameter (m3/kg TSS), and
X; = total suspended solids (TSS) concentration (kgTSS/m3) in layer i.

A criticism of Eqg. 1 is that it over-predicts settling velocities at low concentrations.
Furthermore, the standard Vesilind equation does not account for compression settling. BioWin
employs switching functions to switch off the sludge settling velocity expression at very low
solids concentrations, and also as the solids concentration approaches the maximum solids



compactability in the lower layers of the settling tank. This provides a simplified method of
modeling the poorly flocculating solids in the upper layers of the settling tank, and compression
setting in the lower layers. As the solids concentration in the upper layers approaches a user-
definable concentration (the upper layer settling velocity switch), the settling velocity
approaches zero, and solids are carried upwards by the overflow stream (resulting in solids in
the settling tank effluent). As the solids concentration in the lower layers approaches the user-
definable maximum compactability, the settling velocity is quickly and smoothly reduced to
zero.

The complete settling velocity equation used by BioWin is:

KX X; 1
Vsi:VOe_ l'( )'( — - - — — ) (2)
’ KS + Xi 14+e Compression Settling Transition Factor-(Xpyax—Xi)

Where Ks is the upper layer settling velocity switch, Xuax is the maximum compactability, and
other variables are the same as in Eq. 1.

The switching function effect at low concentrations for a given combination of settling velocity
parameters is shown in the figure below:
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You can increase the suspended solids concentration at which settling velocity is decreased by
increasing the Ks parameter. Varying the Ks parameter is a possible way to vary the predicted
effluent suspended solids.

The switching function effect at high concentrations in the lower layers of the settling tank for a
given combination of settling velocity parameters is shown in the figure below. Lowering the
Xmax parameter is a way to simulate poorly compressible bulking sludge.
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Other Usability Improvements
The following minor fixes have also been implemented in BioWin 5.1:
e You can choose whether or not the Notes window is displayed when you open a BioWin

file, by checking or unchecking the Automatically show notes after loading file box
under Tools > Customize > General

¥ Customize X
Automatic logging ] File locations I System settings I
General l Explorer options Printing options I Report options I
General settings
Recent fie list [10T2] entries
Alarm list [25T2] enties ™ Suppress alarms in dynamic smulations
[V Autosave dynamic runs every ﬂ days

[V Autosave [temporary file with extension ".abw ", File deleted on normal program termination.

[V Pre-allocate database memory for dynamic simulatigns - € updates
[V Check for updates on exit (if connection exis| ynamic simulation table updates

[V Automatically show notes after loading file I~ Enhanced tolerances list enabled

Element State variable naming

Show names for : & Full names " Abbreviated (IWA)

Ideal primary settling tank ~ -
V| Aerobic Digester Abbreviated (cryptic)

V| Anaerobic Digester

V| Variable volume bioreactor Parameter defaults

V| Bioreactor -

| Membrane bioreactor Edit parameter defaults ...

| BOD Influent

| Methanol addition
Ml Aarifior

Reset BioWin Defaults

e Users of previous versions of BioWin reported a “sluggish” behavior in BioWin files that
incorporated very large tables in the BioWin Album. This is no longer the case, so long as
the user does not set BioWin to update tables continually during simulations. The
Steady state simulation table updates and Dynamic simulation table updates
checkboxes should remain at the default unchecked state.
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Mndal Azrifiar

e A progress bar now shows at the bottom of the simulation control box while BioWin
places numerical seed values in all flowsheet elements. This will only be readily evident
on large flowsheets with many elements.

e Improved plotting series naming for multi-layer elements (e.g. SAF).
e Itis now possible to display a Rates window for a SAF element.

e Tighter numerical adherence to splitters with “zero” fractions and rates specified for a
stream.

e Anaerobic digesters and variable volume bioreactors may now be set to “constant”
volume.

e Biofilm details tables in the Album may now be copied to the clipboard for exporting to
Excel.

e The software package that BioWin uses for its charting engine (TeeChart) has updated
to a new version. The functionality is similar to what it was in previous BioWin versions,
but the interface has changed somewhat.
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